I just now got linux; therefore, I need to download a few things. I need to download flash player, so I can watch videos on Youtube. However, when I download it, it tells me:

"Could not open "flash-plugin-10.0.32.18-release.i386.rpm"

Archive type not supported."

Okay. Then how do I do this? Will I get this message every time I try to download a program to Linux?

Yes, I did try to download one of the many Linux versions of Flash. I know it’s not my computer because my dad’s computer done the same thing that mine is doing.
This is a new computer with Windows 7 Ultimate beta version and Vista. I am just playing with Linux for fun.
I got it to work. I already know who’s going to get the best answer. Thanks. I just needed that little piece of info.